RomRaider Logo

RomRaider

Open Source ECU Tools
 FAQ •  Register •  Login 

RomRaider

Documentation

Community

Developers

It is currently Tue Jan 16, 2018 11:49 am

All times are UTC - 5 hours [ DST ]





Post new topic Reply to topic  [ 14 posts ] 
Author Message
 Post subject: EDM 03 WRX ECU Bricked
PostPosted: Sat Dec 10, 2011 7:39 pm 
Offline
Newbie

Joined: Fri Nov 04, 2011 7:34 pm
Posts: 10
Location: New York, NY
Hi,

Today I was trying to reflash my ECU with OpenPort 2.0. While flashing suddenly it said "programming voltage too high" so I closed the ignition and opened the headlights (did this 2 times). On my last try, the ECU stopped responding;

[21:07:11.687] Device Firmware Version: 1.10.3020
[21:07:16.723] denso02_bootloader_cmd_start
[21:07:17.967] denso02_bootloader_cmd_start
[21:07:19.209] denso02_bootloader_cmd_start
[21:07:20.451] denso02_bootloader_cmd_start
[21:07:21.693] denso02_bootloader_cmd_start
[21:07:22.110] kernel get version
[21:07:22.426] interface close
[21:07:22.444] interface close

The car won't run.
When I disconnect the green connectors, it continues to cycle the fuel pump (but not the fans) BUT if I disconnect the battery, it stops cycling until I connect green connectors.
I've tried disconnecting the battery but no luck.
My ECU is not SH705x so I can't use the "sh recovery" procedure.

Any suggestions?

Thanks.


Top
 Profile  
 
 Post subject: Re: EDM 03 WRX ECU Bricked
PostPosted: Mon Dec 12, 2011 2:32 pm 
Offline
Experienced

Joined: Wed Jul 16, 2008 7:32 pm
Posts: 307
mrtcn wrote:
Hi,

Today I was trying to reflash my ECU with OpenPort 2.0. While flashing suddenly it said "programming voltage too high" so I closed the ignition and opened the headlights (did this 2 times). On my last try, the ECU stopped responding;

[21:07:11.687] Device Firmware Version: 1.10.3020
[21:07:16.723] denso02_bootloader_cmd_start
[21:07:17.967] denso02_bootloader_cmd_start
[21:07:19.209] denso02_bootloader_cmd_start
[21:07:20.451] denso02_bootloader_cmd_start
[21:07:21.693] denso02_bootloader_cmd_start
[21:07:22.110] kernel get version
[21:07:22.426] interface close
[21:07:22.444] interface close

The car won't run.
When I disconnect the green connectors, it continues to cycle the fuel pump (but not the fans) BUT if I disconnect the battery, it stops cycling until I connect green connectors.
I've tried disconnecting the battery but no luck.
My ECU is not SH705x so I can't use the "sh recovery" procedure.

Any suggestions?

Thanks.

I would call tactrix. They may be able to help you.


Top
 Profile  
 
 Post subject: Re: EDM 03 WRX ECU Bricked
PostPosted: Wed Dec 14, 2011 5:20 pm 
Offline
Administrator
User avatar

Joined: Wed Oct 25, 2006 12:32 am
Posts: 3040
Unfortunately, I don't think Tactrix provides ecu flash recovery for 16 bit ecus anymore. I think he said that it was more effort than it was worth since.

You may have to get a used ecu.


Top
 Profile  
 
 Post subject: Re: EDM 03 WRX ECU Bricked
PostPosted: Fri Dec 16, 2011 8:03 am 
Offline
Newbie

Joined: Fri Nov 04, 2011 7:34 pm
Posts: 10
Location: New York, NY
Well I've fixed it myself 8) thanks anyway.


Top
 Profile  
 
 Post subject: Re: EDM 03 WRX ECU Bricked
PostPosted: Fri Dec 16, 2011 9:57 am 
Offline
RomRaider Developer

Joined: Wed May 20, 2009 9:49 pm
Posts: 5697
Location: Canada eh!
Can you share how you did that?


Top
 Profile  
 
 Post subject: Re: EDM 03 WRX ECU Bricked
PostPosted: Wed May 23, 2012 9:30 pm 
Offline
Newbie

Joined: Fri Nov 04, 2011 7:34 pm
Posts: 10
Location: New York, NY
dschultz wrote:
Can you share how you did that?


Sure.

1. Disconnect the battery
2. Disconnect the ECU
3. Connect the battery
4. Connect the ECU sockets with the order 1 to 5 (bottom-to-up)
5. Try to test-write (or you can just try to write :))

and voila :)


Top
 Profile  
 
 Post subject: Re: EDM 03 WRX ECU Bricked
PostPosted: Wed May 23, 2012 10:07 pm 
Offline
Newbie

Joined: Sat Mar 18, 2006 2:14 pm
Posts: 84
Location: Auckland
mrtcn wrote:
Hi,

Today I was trying to reflash my ECU with OpenPort 2.0. While flashing suddenly it said "programming voltage too high" so I closed the ignition and opened the headlights (did this 2 times). On my last try, the ECU stopped responding;

[21:07:11.687] Device Firmware Version: 1.10.3020
[21:07:16.723] denso02_bootloader_cmd_start
[21:07:17.967] denso02_bootloader_cmd_start
[21:07:19.209] denso02_bootloader_cmd_start
[21:07:20.451] denso02_bootloader_cmd_start
[21:07:21.693] denso02_bootloader_cmd_start
[21:07:22.110] kernel get version
[21:07:22.426] interface close
[21:07:22.444] interface close

The car won't run.
When I disconnect the green connectors, it continues to cycle the fuel pump (but not the fans) BUT if I disconnect the battery, it stops cycling until I connect green connectors.
I've tried disconnecting the battery but no luck.
My ECU is not SH705x so I can't use the "sh recovery" procedure.

Any suggestions?

Thanks.



Never. EVER. turn off the ignition after a failed flash. Just keep trying to reflash. If you turn it off you will clear the flash kernel out of RAM leading to a brick.


Top
 Profile  
 
 Post subject: Re: EDM 03 WRX ECU Bricked
PostPosted: Mon Jun 02, 2014 11:30 am 
Offline
Newbie

Joined: Sun Jun 30, 2013 8:12 pm
Posts: 68
mrtcn wrote:
dschultz wrote:
Can you share how you did that?


Sure.

1. Disconnect the battery
2. Disconnect the ECU
3. Connect the battery
4. Connect the ECU sockets with the order 1 to 5 (bottom-to-up)
5. Try to test-write (or you can just try to write :))

and voila :)


You are a life saver! I was already prepared to buy a replacement ecu, luckily i tried your method first. Well the lesson learnt here is not to turn off the ignition when it fails =))


Top
 Profile  
 
 Post subject: Re: EDM 03 WRX ECU Bricked
PostPosted: Tue May 31, 2016 4:00 pm 
Offline
Newbie

Joined: Mon Sep 22, 2014 11:41 am
Posts: 26
mrtcn wrote:
dschultz wrote:
Can you share how you did that?


Sure.

1. Disconnect the battery
2. Disconnect the ECU
3. Connect the battery
4. Connect the ECU sockets with the order 1 to 5 (bottom-to-up)
5. Try to test-write (or you can just try to write :))

and voila :)


Does this method really work for 16 bit bricked ECU? So if you flash a corrupted file and the car will not start for example, you can recover it with this method? I exctually can´t really believe that, or the ROM was not really deleted from EcuFlash. Can someone confirm that procedure with a total software bricked ECU?


Top
 Profile  
 
 Post subject: Re: EDM 03 WRX ECU Bricked
PostPosted: Mon Oct 17, 2016 4:13 am 
Offline
Newbie

Joined: Sun Jun 30, 2013 8:12 pm
Posts: 68
SubiCarLous wrote:
mrtcn wrote:
dschultz wrote:
Can you share how you did that?


Sure.

1. Disconnect the battery
2. Disconnect the ECU
3. Connect the battery
4. Connect the ECU sockets with the order 1 to 5 (bottom-to-up)
5. Try to test-write (or you can just try to write :))

and voila :)


Does this method really work for 16 bit bricked ECU? So if you flash a corrupted file and the car will not start for example, you can recover it with this method? I exctually can´t really believe that, or the ROM was not really deleted from EcuFlash. Can someone confirm that procedure with a total software bricked ECU?


Problem I had previously was I flashed a working map, but got interrupted in the middle so the flash failed. After that I couldn't flash a map again, im assuming it was bricked. But it works after I use the method above.

If you had a flash a corrupted file I'm not sure, u can give it a try but flash a previous working file that you know.


Top
 Profile  
 
 Post subject: Re: EDM 03 WRX ECU Bricked
PostPosted: Mon Oct 17, 2016 1:28 pm 
Offline
Experienced

Joined: Tue May 24, 2016 1:45 am
Posts: 168
Fused wrote:
mrtcn wrote:
Hi,

Today I was trying to reflash my ECU with OpenPort 2.0. While flashing suddenly it said "programming voltage too high" so I closed the ignition and opened the headlights (did this 2 times). On my last try, the ECU stopped responding;

[21:07:11.687] Device Firmware Version: 1.10.3020
[21:07:16.723] denso02_bootloader_cmd_start
[21:07:17.967] denso02_bootloader_cmd_start
[21:07:19.209] denso02_bootloader_cmd_start
[21:07:20.451] denso02_bootloader_cmd_start
[21:07:21.693] denso02_bootloader_cmd_start
[21:07:22.110] kernel get version
[21:07:22.426] interface close
[21:07:22.444] interface close

The car won't run.
When I disconnect the green connectors, it continues to cycle the fuel pump (but not the fans) BUT if I disconnect the battery, it stops cycling until I connect green connectors.
I've tried disconnecting the battery but no luck.
My ECU is not SH705x so I can't use the "sh recovery" procedure.

Any suggestions?

Thanks.



Never. EVER. turn off the ignition after a failed flash. Just keep trying to reflash. If you turn it off you will clear the flash kernel out of RAM leading to a brick.

This


Top
 Profile  
 
 Post subject: Re: EDM 03 WRX ECU Bricked
PostPosted: Tue Oct 18, 2016 10:44 pm 
Offline
Newbie

Joined: Fri Oct 12, 2012 2:20 pm
Posts: 36
mrtcn wrote:
dschultz wrote:
Can you share how you did that?


Sure.

1. Disconnect the battery
2. Disconnect the ECU
3. Connect the battery
4. Connect the ECU sockets with the order 1 to 5 (bottom-to-up)
5. Try to test-write (or you can just try to write :))

and voila :)


I have a bricked ECU at home from a USDM 04.
mrtcn, What do you mean by sockets on step 4? the multi-pin connectors that plug right into the side of the ecu box?

I'll have to try this out for sure...


Top
 Profile  
 
 Post subject: Re: EDM 03 WRX ECU Bricked
PostPosted: Mon Sep 25, 2017 12:35 pm 
Offline
Newbie

Joined: Thu Aug 27, 2009 8:35 am
Posts: 7
mrtcn wrote:
dschultz wrote:
Can you share how you did that?


Sure.

1. Disconnect the battery
2. Disconnect the ECU
3. Connect the battery
4. Connect the ECU sockets with the order 1 to 5 (bottom-to-up)
5. Try to test-write (or you can just try to write :))

and voila :)


Thank you my friend.

This procedure worked perfect for me. I recovered a 2004 Jdm Sti 16bits Ecu bricked by a customer. He was ready to buy a new ecu but you saved his a**. Thank you!

I just wonder... could it work for 32bits ecus? Will try when somebody bricks another one around.


Top
 Profile  
 
 Post subject: Re: EDM 03 WRX ECU Bricked
PostPosted: Sun Dec 10, 2017 6:30 pm 
Offline
Newbie

Joined: Thu Mar 23, 2006 1:53 am
Posts: 5
Well, I made the mistake too. 2002 wrx, low voltage flash/crash, and did the one thing you are not supposed to do - turned off the ignition.

I got it on a charger, but it still wasn't going into test mode, and had all the symptoms of a brick. I was a little skeptical reading this thread, but I disconnected it overnight and came back later.

Wow

After reconnecting everything, it only had test mode, whether the green TM connecters were together or not. This seemed like a good thing. I have a combo V1 AccessPort StreetTuner RAM and use the Open Source. Neither would flash at first, but i remembered about pushing the OK button on the first Chime ding on the AP, (it's been years) and that got it back to Stock, and no longer bricked.

Thank guys
Matt


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 14 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Style based on FI Subsilver by phpBBservice.nl