RomRaider Logo

RomRaider

Open Source ECU Tools
 FAQ •  Register •  Login 

RomRaider

Documentation

Community

Developers

It is currently Thu Dec 14, 2017 1:11 pm

All times are UTC - 5 hours [ DST ]





Post new topic Reply to topic  [ 11 posts ] 
Author Message
 Post subject: op20pt32.dll not found in C:\WINDOWS\system32
PostPosted: Fri Apr 07, 2017 11:06 am 
Offline
Newbie

Joined: Fri Apr 07, 2017 11:00 am
Posts: 25
Have seen many with same problem but i can't find any solution to this.
Running with Windows 10 and every time i fire upp Learning View (latest one) i get this in my log file
[15:13:11.2815019] Learning View version 0.6a
[15:13:18.2038548] op20pt32.dll not found in C:\WINDOWS\system32
[15:13:18.2349667] COM3 open
[15:13:18.2662185] ECU Init

Don't know why it complains since Learning View seems to work anyway. EcuFlash can't connect though.
Any solution? I've even tried to manually put the op20pt32.dll file in system32 folder but that did not help.


Top
 Profile  
 
 Post subject: Re: op20pt32.dll not found in C:\WINDOWS\system32
PostPosted: Fri Apr 07, 2017 3:05 pm 
Offline
RomRaider Developer

Joined: Wed May 20, 2009 9:49 pm
Posts: 5659
Location: Canada eh!
op20pt32.dll is for the Openport 2 cable.
Try installing the Openport 2 drivers using the provided installation tool found in the openecu program directory. If EcuFlash can't connect either it's a clear case the driver is not installed correctly.


Top
 Profile  
 
 Post subject: Re: op20pt32.dll not found in C:\WINDOWS\system32
PostPosted: Fri Apr 07, 2017 4:27 pm 
Offline
Newbie

Joined: Fri Apr 07, 2017 11:00 am
Posts: 25
dschultz wrote:
op20pt32.dll is for the Openport 2 cable.
Try installing the Openport 2 drivers using the provided installation tool found in the openecu program directory. If EcuFlash can't connect either it's a clear case the driver is not installed correctly.


Thanks. Thought i already installed that driver but i will give it a new try tomorrow.


Top
 Profile  
 
 Post subject: Re: op20pt32.dll not found in C:\WINDOWS\system32
PostPosted: Wed Apr 12, 2017 5:58 am 
Offline
Newbie

Joined: Fri Apr 07, 2017 11:00 am
Posts: 25
Tried again yesterday and same problem occurs.
Tried to reinstall EcuFlash 1.44 twice with no luck. Even tried to install Drivers + J2534 DLL even if it says -This is an Openport 2.0 driver and J2534 DLL-only install for users who only intend to use non-EcuFlash software with their Openport 2.0. This install also contains a few J2534 coding examples for developers in C. If you plan to use EcuFlash, do not download these files - go to the EcuFlash download page instead, as the driver and J2534 DLL installation are built into the EcuFlash install. but that did not help much either.


Top
 Profile  
 
 Post subject: Re: op20pt32.dll not found in C:\WINDOWS\system32
PostPosted: Wed Apr 12, 2017 9:04 am 
Offline
RomRaider Developer

Joined: Wed May 20, 2009 9:49 pm
Posts: 5659
Location: Canada eh!
You are using an Openport 2 cable?


Top
 Profile  
 
 Post subject: Re: op20pt32.dll not found in C:\WINDOWS\system32
PostPosted: Wed Apr 12, 2017 10:36 am 
Offline
Newbie

Joined: Fri Apr 07, 2017 11:00 am
Posts: 25
No idea tbh. It came with the car and only i was told was that it is a Tactrix cable :)
It looks like this
Image

Learning View works fine except the error message in the log. EcuFlash down not work.


Top
 Profile  
 
 Post subject: Re: op20pt32.dll not found in C:\WINDOWS\system32
PostPosted: Wed Apr 12, 2017 10:59 am 
Offline
Moderator
User avatar

Joined: Sat Jul 06, 2013 8:55 am
Posts: 2050
Location: NI
that's not a 2.0 - that looks like a 1.3 cable if it's a tactrix cable - could also be it's just the SSM cable for reading/logging. What shows up in device manager when you plug it in? You probably want to look at upgrading that to a 2.0 cable for the SD card logging in the future though.

_________________
Good luck and may the logs be ever in your favour!


MY06 EDM STi Type UK Spec D
============================
Panel Filter/2.5" Decat/Prodrive Springs/Leather Seats


Top
 Profile  
 
 Post subject: Re: op20pt32.dll not found in C:\WINDOWS\system32
PostPosted: Wed Apr 12, 2017 11:17 am 
Offline
Newbie

Joined: Fri Apr 07, 2017 11:00 am
Posts: 25
Ok, but the 1.3 cable will work with EcuFlash anyway?
In device manager it said -Serial port (com3) but i manually installed the drivers and now it says -OpenPort 1.3 Subaru (as Serial Port (COM3)


Top
 Profile  
 
 Post subject: Re: op20pt32.dll not found in C:\WINDOWS\system32
PostPosted: Wed Apr 12, 2017 11:37 am 
Offline
Moderator
User avatar

Joined: Sat Jul 06, 2013 8:55 am
Posts: 2050
Location: NI
oh happy days, so it's an openport cable then - yeh should still work for reading/flashing/logging.

_________________
Good luck and may the logs be ever in your favour!


MY06 EDM STi Type UK Spec D
============================
Panel Filter/2.5" Decat/Prodrive Springs/Leather Seats


Top
 Profile  
 
 Post subject: Re: op20pt32.dll not found in C:\WINDOWS\system32
PostPosted: Wed Apr 12, 2017 12:44 pm 
Offline
Newbie

Joined: Fri Apr 07, 2017 11:00 am
Posts: 25
Thanks mate. Gonna give it try tomorrow and see if it's working


Top
 Profile  
 
 Post subject: Re: op20pt32.dll not found in C:\WINDOWS\system32
PostPosted: Wed Apr 12, 2017 3:38 pm 
Offline
RomRaider Developer

Joined: Wed May 20, 2009 9:49 pm
Posts: 5659
Location: Canada eh!
Since it's not an Openport 2 cable you can ignore the log entry:
[15:13:18.2038548] op20pt32.dll not found in C:\WINDOWS\system32
this it just informational.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 11 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Style based on FI Subsilver by phpBBservice.nl