RomRaider Logo

RomRaider

Open Source ECU Tools
 FAQ •  Register •  Login 

RomRaider

Documentation

Community

Developers

It is currently Fri Jan 19, 2018 9:10 am

All times are UTC - 5 hours [ DST ]





Post new topic Reply to topic  [ 84 posts ]  Go to page 1, 2, 3, 4, 5, 6  Next
Author Message
 Post subject: RomRaider Learning Table Values feature
PostPosted: Sat Jul 06, 2013 2:00 pm 
Offline
RomRaider Developer

Joined: Wed May 20, 2009 9:49 pm
Posts: 5698
Location: Canada eh!
Learning Table Values Tool in the RomRaider Logger...
Attachment:
romraiderLTV_20130704-232615.png

This LTV reader requires a logger.xml with Extended parameters defined for your ECU ID. In addition it also requires an ECU definition for your CAL ID be set in the RomRaider Editor Definition Manager listing before you launch the Logger.
Attachment:
ecu_def_manager.png
The ECU definition provides information for these tables (ECU dependent):
  • A/F Learning #1 Airflow Ranges or A/F Learning Airflow Ranges
  • Fine Correction Columns (Load)
  • Fine Correction Rows (RPM)
Caveat: Some early 32-bit ECUs (typically those ROMs 512kb in size) do not allow for reading portions of the ROM via SSM. This can impact reading the A/F Learning airflow ranges and the FLKC load and RPM ranges which results in display of 0s for the ranges.

I need some feedback to assist with the determination of the FLKC data table location in RAM. For ROMs where calculating the address doesn't work I've reserved a new Extended parameter ID (E173) to specify the address.

Vehicle Information alternate units of measure. The units for parameters displayed follow the units selected on the Data tab of the Logger.

For Subaru there's also a SSM based DTC Reader and a Global Timing & RPM adjuster too.

Supports BMW MS4x DME too!

EDIT: test files removed as there was a problem with refreshing the display after subsequent reads. This feature is in version 0.5.7 and higher.


You do not have the required permissions to view the files attached to this post.


Top
 Profile  
 
 Post subject: Re: RomRaider Learning Table Values feedback request
PostPosted: Sat Jul 06, 2013 3:42 pm 
Offline
Experienced
User avatar

Joined: Thu Jul 23, 2009 1:46 pm
Posts: 853
Excellent work!! Can't wait to test it out. :mrgreen:

I'm curious, why the secret development (not on git)? This is a perfect use case for a branch and snapshot.

_________________
Please do not send me support questions via PM, use the forum instead!


Top
 Profile  
 
 Post subject: Re: RomRaider Learning Table Values feedback request
PostPosted: Sat Jul 06, 2013 4:21 pm 
Offline
Experienced
User avatar

Joined: Thu Jul 23, 2009 1:46 pm
Posts: 853
Tested on A8DH202X, everything seems to be working proper. :mrgreen:

_________________
Please do not send me support questions via PM, use the forum instead!


Top
 Profile  
 
 Post subject: Re: RomRaider Learning Table Values feedback request
PostPosted: Sat Jul 06, 2013 6:25 pm 
Offline
RomRaider Developer

Joined: Wed May 20, 2009 9:49 pm
Posts: 5698
Location: Canada eh!
Merp wrote:
Excellent work!! Can't wait to test it out. :mrgreen:

I'm curious, why the secret development (not on git)? This is a perfect use case for a branch and snapshot.

It's not secret, the only part that's not committed remotely yet is the Learning Tables update, the rest is there already.


Top
 Profile  
 
 Post subject: Re: RomRaider Learning Table Values feedback request
PostPosted: Sun Jul 07, 2013 1:31 pm 
Offline
Experienced
User avatar

Joined: Thu Jul 23, 2009 1:46 pm
Posts: 853
I don't think you understood correctly. I was referring to the private development and release build, not the actual code itself which is obviously public after releasing the jar. This is incredibly odd for a FOSS project that uses GIT for SCM, hence my curiosity. It's just really weird to have the right tools at your disposal and ignore them, especially after what happened the last time this was implemented. Is there some benefit to this process I am missing?

_________________
Please do not send me support questions via PM, use the forum instead!


Top
 Profile  
 
 Post subject: Re: RomRaider Learning Table Values feedback request
PostPosted: Sat Jul 20, 2013 12:59 pm 
Offline
Experienced

Joined: Tue Nov 21, 2006 5:31 am
Posts: 337
<3 - dschultz pm me your paypal


Top
 Profile  
 
 Post subject: Re: RomRaider Learning Table Values feedback request
PostPosted: Mon Jul 22, 2013 12:52 am 
Offline
Experienced

Joined: Tue Nov 21, 2006 5:31 am
Posts: 337
I tried to get it working tonight but ran into some issues. I havent tinkered with romraider in a while so I downloaded the latest 0.5.6 RC6 .zip and replaced all of the files in the rr folder. I downloaded your zip and renamed the .jar to .jar.old and dropped your .jar and def in the folder. I tried launching the logger and set the def you provided as the logger def, but when I hit f6 I got an error about ecu defs in the editor. I opened the editor and pointed to the new dtd defs. I tried the logger/f6 again but got the same error.

https://plus.google.com/photos/103956328804038432798/albums/5903293510342922177?authkey=CPOL5Kah5PWCQg

I might just be failing to do something correctly in the process. Any ideas?

Car: 2012 USDM WRX


Top
 Profile  
 
 Post subject: Re: RomRaider Learning Table Values feedback request
PostPosted: Mon Jul 22, 2013 9:38 am 
Offline
RomRaider Developer

Joined: Wed May 20, 2009 9:49 pm
Posts: 5698
Location: Canada eh!
hebs wrote:
I opened the editor and pointed to the new dtd defs.
You need to have the def for your ECU listed in the Editor's Definition Manager...not the DTD file.
In your picture you see CAL ID unknown beside the ECU ID in the lower right of the Logger, this means no ECU def's are set.


Top
 Profile  
 
 Post subject: Re: RomRaider Learning Table Values feedback request
PostPosted: Mon Jul 22, 2013 3:51 pm 
Offline
Experienced

Joined: Tue Nov 21, 2006 5:31 am
Posts: 337
hebs wrote:
I tried to get it working tonight but ran into some issues. I havent tinkered with romraider in a while so I downloaded the latest 0.5.6 RC6 .zip and replaced all of the files in the rr folder. I downloaded your zip and renamed the .jar to .jar.old and dropped your .jar and def in the folder. I tried launching the logger and set the def you provided as the logger def, but when I hit f6 I got an error about ecu defs in the editor. I opened the editor and pointed to the new dtd defs. I tried the logger/f6 again but got the same error.

https://plus.google.com/photos/103956328804038432798/albums/5903293510342922177?authkey=CPOL5Kah5PWCQg

I might just be failing to do something correctly in the process. Any ideas?

Car: 2012 USDM WRX



merp pointed that out on irc last night and I fixed it. I hadnt messed with romraider since last fall so I completely uninstalled and deleted the dir, and then reinstalled. I set the right ecu defs xml in the editor (tried eric's tp defs, and also tried pasting my ae5k500l section from his tp defs into the std ecu defs from the forums)and can open my ae5k500l rom, but i still get the same error about ecu defs when i hit f6 in the logger.


Top
 Profile  
 
 Post subject: Re: RomRaider Learning Table Values feedback request
PostPosted: Mon Jul 22, 2013 5:08 pm 
Offline
RomRaider Developer

Joined: Wed May 20, 2009 9:49 pm
Posts: 5698
Location: Canada eh!
Please send me your rr_system.log and the def you are trying to use and I'll have a look to see what's up.


Top
 Profile  
 
 Post subject: Re: RomRaider Learning Table Values feedback request
PostPosted: Tue Jul 23, 2013 1:53 am 
Offline
Experienced

Joined: Tue Nov 21, 2006 5:31 am
Posts: 337
Here are the ecu and logger defs I am using, and the log file.


You do not have the required permissions to view the files attached to this post.


Top
 Profile  
 
 Post subject: Re: RomRaider Learning Table Values feedback request
PostPosted: Tue Jul 23, 2013 9:33 am 
Offline
RomRaider Developer

Joined: Wed May 20, 2009 9:49 pm
Posts: 5698
Location: Canada eh!
The rr_system.log states:

17853 INFO [Thread-5] - J2534/ISO9141 connection initialised
18113 INFO [Thread-5] - ECU ID = 8112585007
18115 INFO [AWT-EventQueue-0] - CAL ID: null, Car: null
18309 INFO [AWT-EventQueue-0] - Loading logger config for new ECU ID: 8112585007, loaded SSM: 117 parameters, 40 switches from def version 155.


Checking the ecu_def.xml you provided there is no match in it for ECU ID: 8112585007
You need to download the ECU def I linked in my previous post for your car and add it to the Definition Manager in the Editor before attempting to use the Learning Table Values tool. The ECU specific def is needed as it contains the location for the AF Learning and FLKC tables, without it the logger doesn't know where the tables are in memory.


Top
 Profile  
 
 Post subject: Re: RomRaider Learning Table Values feedback request
PostPosted: Tue Jul 23, 2013 10:41 am 
Offline
Experienced

Joined: Tue Nov 21, 2006 5:31 am
Posts: 337
dschultz wrote:
The rr_system.log states:

17853 INFO [Thread-5] - J2534/ISO9141 connection initialised
18113 INFO [Thread-5] - ECU ID = 8112585007
18115 INFO [AWT-EventQueue-0] - CAL ID: null, Car: null
18309 INFO [AWT-EventQueue-0] - Loading logger config for new ECU ID: 8112585007, loaded SSM: 117 parameters, 40 switches from def version 155.


Checking the ecu_def.xml you provided there is no match in it for ECU ID: 8112585007
You need to download the ECU def I linked in my previous post for your car and add it to the Definition Manager in the Editor before attempting to use the Learning Table Values tool. The ECU specific def is needed as it contains the location for the AF Learning and FLKC tables, without it the logger doesn't know where the tables are in memory.


Oh I must have overlooked the inline link to the defs. I will try this out shortly.


Top
 Profile  
 
 Post subject: Re: RomRaider Learning Table Values feedback request
PostPosted: Tue Jul 23, 2013 9:28 pm 
Offline
Experienced

Joined: Tue Nov 21, 2006 5:31 am
Posts: 337
Ok lv is working now and the data looks correct.

Thanks for your work on this new lv and the help getting things working again.


Last edited by hebs on Wed Jul 24, 2013 1:51 pm, edited 1 time in total.

Top
 Profile  
 
 Post subject: Re: RomRaider Learning Table Values feedback request
PostPosted: Tue Jul 23, 2013 10:27 pm 
Offline
RomRaider Developer

Joined: Wed May 20, 2009 9:49 pm
Posts: 5698
Location: Canada eh!
Good news.

For the other problem please start a new thread to keep this one on topic.
thanks


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 84 posts ]  Go to page 1, 2, 3, 4, 5, 6  Next

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Style based on FI Subsilver by phpBBservice.nl