Search RomRaider

RomRaider

Documentation

Community

Developers



  • View Page
  • Page History/Versions
  • Print Page

Table Navigation

Navigation in RomRaider is designed to be as straightforward and convenient as possible. Experienced tuners should find most aspects of the interface familiar and be right at home in the environment. We’ve done our best to combine the best aspects of different tuning applications and added a few of our own.

1.  The graphical interface


Table Display

The toolbar on the graphical interface should be familiar. The buttons are standard and pretty self explanatory, but here is a quick rundown of the functions you will find.

  • 1) Fine increment/decrement : Clicking on these buttons will raise or lower the value of selected cells
  • 2) Increment by (fine) field : Value to increment/decrement selected cells by when clicking fine buttons
  • 3) Coarse increment/decrement : Clicking these buttons will raise or lower the value by an amount larger than the fine increment and decrement buttons, with a increment by field to define the amount
  • 4) Set/multiply value field : User-definable text field to set values to or multiply values by
  • 5) Set : Sets selected values to that specified in the set value text field
  • 6) Mul : Multiplies selected values by factor in set value text field

2.  Keyboard navigation

Tuners would often rather use keyboard navigation as it can be faster, especially in a tuning environment where you may be using a laptop. The following keyboard command can be used to navigate tables and manipulate their data.

  • Arrow keys : Move cursor
  • Ctrl + Up/Down : Coarse increment/decrement selected values
  • Ctrl + Shift + Up/Down : Fine increment/decrement selected values
  • ± : Coarse increment/decrement selected values
  • Ctrl + ± : Fine increment/decrement selected values
  • 0–9, . : Typing a number will set focus to the set value text field
  • <Enter> : Sets selected values to number in set value text field
  • Ctrl + <Enter> : Multiplies selected values by factor in set value text field
  • Ctrl + <Click> : Selects multiple cells

3.  Table menu options

  • Table Menu
    • View Graph : Currently not enabled. Will display 2D or 3D graph of table in future release
    • Overlay Log : Currently not enabled. Will highlight relevent cells from datalog in future release
    • Compare : Allows you to compare table values to original values or to another table
      • Display : Allows you to choose between absolute and percent difference
    • Close (Table Name) : Closes selected table
  • Edit Menu
    • Undo Selected Changes : Reverts selected cells to last revert point
    • Undo All Changes : Reverts all cells to last revert point
    • Set Revert Point : Sets revert point for all cells
    • Copy Selection : Copies all selected cells to clipboard paste into spreadsheet or another table
    • Copy Table : Copies entire table to clipboard to paste into spreadsheet or another table
    • Paste : Pastes clipboard into table. If a selection is found in clipboard, paste begins from the first selected cell
  • View Menu
    • Table Properties : Displays table properties including description, storage information and conversion methods



Forum

RomRaider Forums

Join our forums, the best place to find help and answers!





Donate


RomRaider is developed and supported by volunteers working on their own time. To support their efforts please consider making a donation.





Page last modified on January 17, 2007, at 02:17 PM
Powered by PmWiki